Set Password checkbox doesn't stick

Running Octopus Deploy 3.2.22.

When setting up the IIS application pool and using a custom user, the “Set Password” checkbox does not save.

To reproduce:

  1. Set Identity to “Custom user…”
  2. Set Username to a variable “#{Username}”
  3. Check “Set Password”
  4. Set Password to a variable “#{Password}”
  5. Click Save
  6. Reopen the step definition

Expected Result:
The “Set Password” checkbox will be checked and the password variable will be shown.

Actual Result:
The “Set Password” checkbox is unchecked and the password variable is not visible.

Hi Justin,

Thank you for reaching out! I have confirmed while testing on 3.3.22 that this issue has been resolved. It was fixed in 3.3.0, so an upgrade to a newer version should resolve this for you!

I hope that helps!


Awesome. Thank you.