Project Variable Templates Default Value not showing

We have recently upgraded to Octopus Server 2020.3.2 and have noticed that now when I associate a tenant to a project+environment the default values for variable templates in that project do not actually receive the default value, they are all blank. I have to go in and manually click ‘Reset to default’ for the value to populate in the UI. I also have noticed that when I fill in values for the default=empty variable templates, I need to reload the tenant page (after saving) in order for the warning icon to go away. So the pairing of the icon not disappearing when the required values are set + default values showing as empty makes it extremely difficult to know when I am actually missing configuration for a variable template.

To be clear, the default values for the variable templates ARE used in a deployment even if they appear blank on the tenant + project variable page. I can deploy a project with a variable template that has a default value without additional changes. I believe this is just some strange interaction with how variable templates are managed by Octopus. The variable templates are held GUID + name + default value, and only if a tenant overwrites the default value is there a specific variable of ‘GUID = non-default value’ created. The deployment gets all the default values for template and then overrides the non-defaults when an appropriate GUID variable is a part of the project (or something to this effect).

Hi @hardKOrr

Thanks for reaching out and all of the great information.

This is actually a known issue and has been resolved in 2020.3.3.

2020.3.3 should be out very soon for download.

Please let me know if you have any other questions or concerns.


1 Like

Great news, I had looked around on here for a similar report but didn’t check out over at github.


1 Like

You’re very welcome! I hope you have a great weekend.


I just upgraded to 2020.3.3, and the problem has not been solved. I have also left a comment on the github issue listed above.
Not sure of any additional steps that may be necesasry or helpful


Sorry to hear it didn’t fix your issue.

Are you seeing the exact same symptoms as this screenshot or something different? If it’s something different can you please provide detailed screenshots?


Yes that’s what I am seeing.

There is also the ‘reset to default’ button/link below the value, which will restore to show default value. When I select to ‘reset to default’ it changes to report that it is the default value.

I am seeing no difference in variable functionality after upgrading to 2020.3.3 from 2020.3.2

Hey @hardKOrr,

Can you try doing a Ctrl+F5 on the page? I believe this may be a caching issue.

Please let me know how that goes.


Awesome, that worked! I had initially loaded the octopus UI in chrome incognito tab to attempt to mitigate that being the issue.

Thanks again for all the great work to everyone at Octopus Deploy!

1 Like

You’re very welcome! Thanks for letting me know it worked.

I hope you have a great rest of your week.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.