Octopus Build information step


I am currently testing Teamcity and Octopus integration. Impressed so far, however I am experiencing an issue with one of the build steps.

I have a “build” configuration that takes place in TC which triggers another configuration to “Deploy” The Deploy step is set up with dependencies on the build step artifacts.

The deploy step involves:

  1. Pack
  2. Push
  3. Push Build information

All my steps are working fine however step 3, pushes the build information but the link it provides back to the TC build from the Octopus Packages page goes nowhere and gives me this: https://g.octopushq.com/null/viewLog.html?buildId=26217

I have tried various combinations of the Build number etc but none of the configurations seem to work even though the build numbers are consistent from build through to the deploy step

The latest build I have pushed is referencing: buildId=buildId=26224

But the TC build link is actually buildId=26222

Please help as this has worked when the build information step is part of the same build configuration in TC


Hi @supafly270,

Thanks for getting in touch!

Unfortunately, this is a known behaviour of TC. The Build Information step has to be in the same configuration (i.e. build chain step) that the build is happening in, it cannot be a sub-sequent step because the snapshot dependencies don’t carry the repo and commit change info across that we need.

As a way to understand this, we use the information that appears in the Change section of the build in TC (for commits etc.), so if that is empty, then we can’t see anything.

We’re investigating whether there’s an API where we can walk back up the chain, but there is no progress on that yet.

Best regards,

Thats fine

Thank you

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.