Octo.exe (--Variable)

Hi Team,

I am not able to pass Project level value from " --Variable = Lable:Value " while creating release using Octo.exe.

Can you please help me ?

Santhosh Shet

Hi Santhosh,

Thanks for getting in touch! This --Variable = Lable:Value argument sets the value to the matching prompted variable in the target project, where prompted variable values are supplied at deployment time, rather than release creation time. Meaning instead of passing this in your create-release command, you’d do so in the deploy-release command. This would look something like this: octo.exe deploy-release --variable=Label:Value

You can also pass the --deployto=EnvironmentName argument in your create-release command, and then the --variable argument will be picked up on deploying the new release. This would look like this: octo.exe create-release --project=HelloWorld --deployto=EnvironmentName --variable="Label:Value".

I hope this helps! If that doesn’t help answer what you’re looking to achieve, feel free to elaborate on your use case and we can try to think of some alternative options. :slight_smile:

Best regards,


Hi Kennath,

Thanks for your quick support .
it is not working for me yet :frowning:
Let me explain the scenario in brief , i have one application level variable and i wish to change the value when i try to deploy the application using create-release using Octo.exe.
i have used octo.exe create-release --project=HelloWorld --deployto=EnvironmentName --variable="Label:Value" , but “variable=“Label:Value”`” is not updating , it is still taking value which is given in project level.

Hi @santoshuponi,

Thanks for keeping in touch! Is the variable you’re intending on updating in this command configured as prompted? This is indicated by the speech bubble icon next to the variable’s value like shown below.

Additionally, the label can differ from the variable name. For this same variable example, the label is set as Prompt, so the octo.exe command would have to use variable="Prompt:MyValue". You can see this in the popup after clicking “Open Editor”.

This octo.exe command won’t update the value of a standard project variable.

Let me know if that helps. :slight_smile:

Best regards,


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.