Octo.exe using --packagesFolder, octopus not able to pick version from packages

I’m trying to specify what packages to use when creating a release from TeamCity (v 10.0.4. Octopus v 3.8.1. TC plugin v 4.5.1, have also tried TC plugin v 3.4.2).

  1. TeamCity builds project, creates packages of type *.zip
  2. Another TC project has artifact dependency on the one above, with rule: *.zip => someFolder
    step 1: OctopusDeploy: Push packages. Using packages path: someFolder*.zip
    step 2: OctopusDeploy: Create release. using additional command line arguments: --packagesFolder=someFolder
    (I notice that the “=”-sign is automatically removed when step is running, guess this is correct)

I have tried using just a folder name (“someFolder”) , but also full path to a folder (“c:\tcAgent\work{guid}\someFolder”) but none seems to work.
All I get in the log is: "The package version for some steps was not specified. Going to try and resolve those automatically…"
This happens for all packages for all steps. The “latest version” that octopus finds is the same as the version that exists in the “someFolder” that I specified. Not difficult to verify as I only have three packages in use. (Note: per now we only have packages with 0.0.counter as version, but later on we will have x.y.z but still want to be able to build 0.0-packages, so we need this functionality to work before updating version numbers)
Do you have any idea of what could be the reason for octopus not being able to pick out the version numbers? Could it be due to that I am using *.zip instead of *.nuget?
Any help is greatly appreciated!
-Gard E.

Hi Gard,

Thanks for reaching out! I’m gonna need a bit more info to properly troubleshoot this one:

  • Could you send me a full build log from TC?
  • Could you also send me a screenshot of the folder that contains this .zip packages? I’m looking forward to attempt to reproduce this by using the same zips as you are using.


Hi Dalmiro,
Thank you for your prompt reply!
I have attached the build log and screenshot of packagesFolder

(And please note, I also have a log that shows the same result, but where
the octo command is
[Octopus Deploy] Running command: octo.exe create-release --server
http://forbuild01:88/ --apikey SECRET --project RGV --enableservicemessages
–version 0.0.281-TC-54 --packagesFolder


Dev_Push_packages_to_Octopus_0.0.281.log (10 KB)

Hi Gard,

Thanks for sending over all that info. Definitely a bug. I’ve logged a github issue to get it fixed: https://github.com/OctopusDeploy/Issues/issues/3148


Thank you, Dalmiro!
Hope fixing this gets a high priority =)