minimumTlsVersion in arm template with Azure storage account

I am trying to upgrade a storage account in azure in an ARM-template which is used in Octopus.
In properties I have added: “minimumTlsVersion”: “TLS1_2”.

But in Octopus I get the message:
Status: BadRequest
Provisioning State: Failed
Status Message: {“error”:{“code”:“InvalidRequestParameters”,“message”:“Request parameters are invalid: minimumTlsVersion.”}}

Adding this in properties has worked before. Does anyone recognize this error message?

Hi @hannes.carleson

Thanks for getting in touch. Sorry to hear that you’ve run into an issue with your ARM template.

I’ll look further into this for you. Could you tell me which version of Octopus you’re using, please? Have you upgraded Octopus since this last worked for you? If possible, could you share your ARM template?

Does the template work outside of Octopus?



The version of octopus is 2019.12.0.
No I have not upgraded octopus. The last time this worked was when an inline powershell script was running and that started working because I added the line “[Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12” there. This on the other hand is a json file running the arm-template.

This is how in looks in the view:


This is the line I have added in the json file:


I am not sure how to run the script anywhere else to see if it works.

Hi @hannes.carleson

Could you try manually configuring a storage account in Azure with TLS1.2 enabled and download the template to try if that works for you, please?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.