Issue in adding nexus as an external feed for hosting docker images internally

I’m trying to add nexus as an external feed and this is what error message(attached below) I get when I try to save and test the feed.

Can anyone help me resolving this issue


I hadn’t tested the Octopus Deploy Docker Registry feed against Nexus 3 until today however It appears to have worked fine for me (see screenshot attached for sample config) using basic authentication. What is the URL you have supplied in the URL section of the configuration. You should be able to browse the repository by putting the Url directly in the browser along with the v2/_catalog suffix. In my case going to brought up

"repositories": []

Since my fresh repository is currently empty. Could you try this from the machine on which your Octopus Deploy server is hosted and let me know if it works.
If this works but your Octopus configuration is still failing, could you please run fiddler or wireshark on this server and check the traffic to make sure the request is actually going out to your repository.
Although you may admittedly be using the repository for testing purposes atm, I might mention that it looks like you are using http as opposed to the recommended https. It is advised that your repository should be protected via a secure connection. Although this shouldn’t be the cause of the problem you are seeing, I thought it wise to point that out.

Let me know how the above tests go,

Hi Rob,

The URL I have used is
I tried with /v2/catalog/ but that gave me HTTP404.
while digging more on this, I found
I followed the exact steps from the above link and reconfigured everything but nothing worked for me.
I don’t understand the exact problem now. let me know if you need more details to resolve this issue.


Hi Niranjan,
If you are receiving a 404 then it appears that you have problems with your registry configuration and not Octopus Deploy. I did notice though in your response that you said you went to but did you see that that in my original reply I indicated that you should go to /_catalog. Notice the underscore before catalog. Could you please ensure that you go to the right address. If you just go to /v2 without the catalog you may still get a valid 200 if your registry is configured correctly. Ultimately if you are unable to connect to the nexus registry from the Octopus server through the browser then this is not a problem with Octopus itself and you may need to fix your registry or network.

Could you please confirm for me that you have properly tested this connection.