Deploy helm chart with Files sourced from the Chart package

When I try to add an additional value file from the package, the script does not apply it. Other options like Raw values YAML or Explicit Key Values work.

Hi Stav,
The Files in Chart Package option looks for the file from the root of the chart package. A standard chart package actually contains a folder with the chart name in the root, which contains all the chart contents. If you include this in the path name it should find the appropriate file.
Rest assured that you aren’t the first user who has hit this issue and I can understand the confusion. We have added to our backlog a fix so that it will make sure it includes this chart root folder for this option.
I hope this hasn’t caused too much confusion.
Let me know if you have any further questions.

My chart name = accounts
In my screenshot - path to yaml .\accounts
I try set like in you hint ( **\config\ , try place file in root, and use key=value format. But in Octopus work folder (then i create release and run deploy) in scripts or some folders nothing to say about my custom values and release deploy in kubernetes with default values

Hi Stav,
I had another dig around in that step and it looks like something might have broken on that feature and the additional values files are not being included. I have logged this as a bug in GitHub and added it to the top of our list of things to sort out. In the meantime are you able to take the configuration and add it as RAW yaml on that step? An alternative workaround, though not ideal, would be to include this config in a different package, and use the file via the Files in additional Packages option. My apologies that neither of these work arounds are perfect but they may help to get you deploying while we work on the bug on our side.
Keep an eye on that issue and let me know if this helps,

No problems =)
We are testing octopus and can wait until the problem is resolved. Hopefully together we can make this tool better.