Can't integrate Jira Cloud and Octopus

I configured Octopus and Jira Connect App installed on Jira Cloud by following the guide.

The TEST button under Release Note Options works well.
But, when I press the TEST button under Jira Connect App Password, I get the error.

Failed to get authentication token from Jira Connect App.

Why is this?


Hi aetos,

Sorry you’re experiencing problems setting this up.

I wonder if it’s to do with permissions. There was a similar ticket a few month back and the cause was
“i had the permissions to add the app i didn’t have the permissions to manage it.”.

Could you give that a try and let us know please.

Thank you

I uninstalled the Octopus app from Jira Cloud, re-installed and reconfigured it with an account that has Jira administrator privileges, but still got the same error message.

I tried integrating Octopus with Jira Cloud with an account that has Jira admin privileges, but without success.
Do I need to have Octopus Deploy administrator privileges to integrate Octopus and Jira?
Since I use Octopus Cloud, I don’t have Octopus Deploy administrator privileges.
Is this feature supported on Octopus Cloud?

When I click the Save button on the ‘Octopus Deploy configuration’ page on Jira Cloud, the request to returned 400 responses.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.