An attempt was made to access a socket in a way forbidden by its access permissions

Server: Windows Server 2008R2
Octopus Tentacle Version: Octopus.Tentacle. (was running, tried upgrading to latest as part of troubleshooting)

This tentacle has been happily running since January with no downtime until June when the socket error occurred,I think after a system reboot. We haven’t done any deploys to that server for a few months which is why I’ve only just noticed it. When I tried to bring it back up today it kept failing with the same error. I then tried uninstalling it and installing the latest version of the Tentacle Agent and got the same. There’s no 3rd party antivirus or firewall shenanigans on this box.

Any ideas?

At the time of the error there is an event log accompanying the octopus log events:
Faulting application name: Tentacle.exe, version:, time stamp: 0x53b5236d
Faulting module name: KERNELBASE.dll, version: 6.1.7601.18015, time stamp: 0x50b8479b
Exception code: 0xe0434352
Fault offset: 0x0000000000009e5d
Faulting process id: 0x12d8
Faulting application start time: 0x01cf979c7a5dfbb2
Faulting application path: C:\Program Files\Octopus Deploy\Tentacle\Tentacle.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: b9cc9182-038f-11e4-9375-005056a61253

Octopus Log:

2014-07-04 16:27:30.6295 INFO Service stopped
2014-07-04 16:27:32.1285 INFO Service uninstalled
2014-07-04 16:27:33.9885 INFO Service installed
2014-07-04 16:27:34.1625 INFO Waiting for service to start. Current status: StartPending
2014-07-04 16:27:35.1635 INFO Waiting for service to start. Current status: Running
2014-07-04 16:27:35.7045 INFO Resolving for Pipefish.Hosting.ActivitySpace
2014-07-04 16:27:36.1645 INFO Service started
2014-07-04 16:27:36.6005 ERROR An attempt was made to access a socket in a way forbidden by its access permissions
System.Net.Sockets.SocketException (0x80004005): An attempt was made to access a socket in a way forbidden by its access permissions
at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.Bind(EndPoint localEP)
at System.Net.Sockets.TcpListener.Start(Int32 backlog)
at Pipefish.Transport.SecureTcp.Server.SecureTcpServer.Start() in y:\work\3cbe05672d69a231\source\Pipefish.Transport.SecureTcp\Server\SecureTcpServer.cs:line 46
at Octopus.Tentacle.Communications.TcpServer.TcpServerDistributionConfig.StartApp() in y:\work\refs\heads\release-2.4\source\Octopus.Tentacle\Communications\TcpServer\TcpServerDistributionConfig.cs:line 87
at Octopus.Tentacle.Communications.TcpServer.TcpServerDistributionConfig.Start() in y:\work\refs\heads\release-2.4\source\Octopus.Tentacle\Communications\TcpServer\TcpServerDistributionConfig.cs:line 52
at Octopus.Tentacle.Communications.DistributionStarter.Start() in y:\work\refs\heads\release-2.4\source\Octopus.Tentacle\Communications\DistributionStarter.cs:line 17
at Octopus.Tentacle.Commands.RunAgentCommand.Start() in y:\work\refs\heads\release-2.4\source\Octopus.Tentacle\Commands\RunAgentCommand.cs:line 50
at Octopus.Shared.Startup.WindowsServiceHost.<>c__DisplayClass2.b__0() in y:\work\refs\heads\release-2.4\source\Octopus.Shared\Startup\WindowsServiceHost.cs:line 19
at Octopus.Shared.Startup.WindowsServiceAdapter.RunService() in y:\work\refs\heads\release-2.4\source\Octopus.Shared\Startup\WindowsServiceAdapter.cs:line 44

I’ve just gone back through my email history, it looks like our sysadmins disabled SSL 2.0 on 12th June which is when Octopus Tentacle failed to start up again. I’ll take a look and see if that is the culprit.

Hi Dan,

Thanks for getting in touch!
Thanks for letting us know about the issue and possible cause.

Please let us know how this works out.

Aha! I found it - Anold 1.6 Octopus Tentacle was still hanging around and claiming port 10933 when the server booted up. I’ve disabled the service, all is well now.

Hi Dan,

That would do it! This should really help in the future when someone has a similar issue to know where to look first.
Thanks for getting back to us and updating the thread! Much appreciated!