When the retention steps are run via a proxy they fail with "Attempted to access Proxy before it has been loaded"

When running a deployment on targets that are accessed via a proxy when it gets to the retention policy steps, the deployment starts throwing the following error for all targets that are accessed via a proxy: “Attempted to access Proxy before it has been loaded”

Warning: Applying retention policy using 1 Items to set Environments-85/Projects-82/Step-EMDashboard - Install-Upgrade EventLogger Service/Machines-846/
20:16:42 Error | Attempted to access Proxy before it has been loaded

Octopus Version: 2018.7.5


Thanks for contacting us. Would it be possible for you to send a complete log of a deployment that’s failed? Hopefully that will tell us something about the problem.

Cam MacFarland

This is the log from the first attempt. After retrying a few of the retention failures and them still failing I then started ignoring the failures to get to the post retention steps. However, eventually the deployment hung and I had to cancel it to get the deploy to stop. I subsequently then rebooted the octopus server and the proxy server in case that helped. I then re-ran the deployment and exactly the same thing happened. Everything worked fine until it got to the retention steps.

ServerTasks-54715.log.txt.zip (229.3 KB)

One follow-up question. What proxy are you using?


ccproxy - http://www.youngzsoft.net/ccproxy/

Also, the last time we did a deployment that went via a proxy was with 2018.6.7 and that worked fine.


We fixed that error message is a recent version of Octopus. Could you please try upgrading to the latest version.

Also, the machine record might be corrupted, so once you’ve upgraded if there’s still a problem try deleting and re-adding the machine to the server.


Cheers, re-running the last deployment with the latest release (2018.7.14) worked without an issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.