When deploying Azure Web Role Windows Authentication mysteriously gets always set to true

We noticed our deployments to a web role for some mysterious reason always end up with Windows Authentication enabled

We’re using a Deploy Nuget Package step, with IIS authentication settings in Octopus setting only Anonymous Authentication to true (the other two are false). WE can even see in the logs that it tries to set Windows Auth to false, and there are no errors, but it every time ends up enabled after a deployment.

Even if we manually remote into the Azure VM, go to IIS settings, flip it back to false, redeploy it ends up being true.

Any ideas?

We were running Octopus 2.3.3, but upgraded to latest ( and it still happens

Hi Krzysztof,

Thanks for getting in touch! Yeah this was a bug we have just recently fixed in 2.5.7 which is now available for download.


OK thanks

Krzysztof Kozmic
sent from my phone