Well Formed URL Error

I was getting the same error as:

I tried with the feed in the following formats from the Page URLS from myget:

But neither of those worked.

What you need to do is instead navigate to ‘Feed Details’ in myget and find the line with:
‘Your NuGet packages feed URL (with authentication)’

And copy that URL which is in the format;

I think Octopus should update their documentation to reflect this:

Also, gotchas in Octopack:
If your project has a space in the solution/project name then the build will fail.
The only solution to this is to create a .nuspec file manually and add to the root of the project.
I think Octopack should be changed to strip out spaces for project names

And another gotha in Octopack:
by default if you build in Visual Studio Online it won’t include Octopack
Instead you have to go to:
Edit that file and change:

Again I think this page should be updated to reflect these requirements:

Hi Marcus,

Thanks for getting in touch. About the MyGet URL, we provide a generic documentation that applies to most of the cases. In this case going to MyGet.com -> Feed Details -> and getting the first URL that MyGet provides seems like a pretty straightforward process.

RE Octopack, those sound like issues that should be submitted on the Octopack project, rather than “gotchas” that should be included on the documentation. Could you please log these on github? https://github.com/OctopusDeploy/OctoPack