Warning: there are no enabled deployment targets in the roles specified by this step, in this environment

Hi Guys - I’m testing version 3.15.0 on my local Octopus installation before upgrading our production server (from 3.14.1) to fix one of our outstanding issues. However, when attempting my first deployment, I am getting this message next to each step in our deployment process (see screen shot). I have only a single deployment target, with two roles, which is enabled for all 10 of our environments. I have experimented with adding and removing the roles, and enabling and disabling the deployment target. If I proceed with the deployment it does actually work, so I don’t know why I am seeing these warning messages. The only way I was able to remove them was to change the Project Deployment Target Settings, and enable the No Targets setting, which allows deployments to be created when there are no deployment targets (which of course there are). This does allow me to continue deploying, but I’m questioning why I need to enable this setting???
Cheers, SImon.



Thanks for reporting this. Could you send me a screenshot of your environments page along with your deployment process overview page?

This will help me reproduce the issue.

If the information is sensitive, you can make this conversation private by clicking the “Make Private” button on the right.

Rob W


One more question, do you (or have you ever) enabled multi-tenancy on that server?

Rob W

Hi Rob - Screenshots attached, and yes, we use multi-tenancy. There are more environments than this, but they are all configured the same way. There are also more process steps obviously, but again they are configured similarly to the ones shown.



Thank you for that, I was able to reproduce the problem. I’ve raised an issue that you can subscribe to to be informed on it’s progress.

From my testing, the deployment can still be created and will still work correctly. The error lies in the deployment validation call not having all the information in it.

Robert W

Thanks Robert, I can see a new version has been released with this fix in it now, thanks for the quick turnaround!
Cheers, Simon.