VSO deploy step does not allow me to enter the api key without ugly hack

I have a Visual Studio Online build with a “Deploy Octopus Release” step in it. The problem is that it is not possible to specify the api key in the “advanced options / additional arguments”. The text I place in the “additional arguments” section is not actually appended to the call to octo.exe (see red arrow in my screenshot).

I have a workaround in that I can append it to the “Deploy to Environments” argument, as shown by the green arrow in my screenshot.

Hi Sidney,

Thanks for getting in touch! I’ve confirmed that additional arguments in the Octopus Release step are not being added to the call to octo.exe, this is a bug. Here is the issue you can track: https://github.com/OctopusDeploy/OctoTFS/issues/47
Thank you for reporting this and for the clear reproduction steps.

However in your case the recommended way of setting the APIKey is to enter it into the “Password/Token Key” field when you set up the Octopus server connection. Take a look at the “Add a Connection to Octopus Deploy” section of our VSTS Documentation page here: http://docs.octopusdeploy.com/display/OD/Use+the+Team+Foundation+Build+Custom+Task

Hope that helps!