Variable for email address list, in email, not resolving


strange thing happening.

I have a variable with a list of email addresses. I tried separating the email addresses with a semi-colon, and a comma. Both produce the same result in the raw log, the “To:” address, is the list of email addresses separated by a comma. and the email is not sent.

                |   == Success: Step 6: EmailNotification ==

09:27:40 Verbose | EmailNotification completed
| Success: Octopus Server
09:27:39 Verbose | Octopus Server version: 3.4.14+Branch.master.Sha.2bb81229f335511f625ca4fe6832e2752c1565a0
09:27:39 Verbose | Email parameters:
09:27:39 Verbose | Subject: OctopusDeploy; Promotion of MyProject to CoreDevelopment
09:27:39 Verbose | To:,
09:27:39 Verbose | Cc:
09:27:39 Verbose | Bcc:
09:27:39 Verbose | Sending email message…
09:27:40 Info | Email sent!

Step, email “To”: #{EmailMyProjectPromotion}

Variable defined:

(with the semi-colon)

Hi Michael,

Thanks for getting in touch! I’m sorry to hear you’re hitting this unexpected behavior. In my local testing, a variable with multiple email addresses (separated by comma or semi-colon) worked as expected, though I was running the latest version. I believe support for this would have been added in conjunction with the following issue that was implemented in 3.7.9.

Would you be able/willing to upgrade (preferably to latest) and let me know if this fixes this up for you?

Otherwise I’ll be happy to look into this further. Could you provide some additional details to ensure I’m attempting to replicate accurately?

How is the EmailMyProjectPromotion scoped?
Could you attach a copy of your verbose deployment logs with debugging variables enabled? The following doc page outlines how you can produce and export this log.

I hope this helps, and I look forward to hearing back!

Best regards,


I think I figured it out. If I separate the addresses with a semi-colon and a space it works. If i leave no spaces it does not work

Mike Abramovitch

Vice President, Software Development

P. +1 905 413 8737 | M.+1 416-402-1848 |


This message, including attachments, is intended only for the use of those to whom it is addressed and may be confidential. Distribution, copying or disclosure is prohibited. If you received this message in error, please notify me immediately by reply email and permanently delete this message and attachments. Ce message (incluant ses fichiers joints) est transmis pour l’usage exclusif des personnes à qui il est destiné et peut être confidentiel. Il est interdit d’en faire la distribution, la copie ou la divulgation. Si vous avez reçu ce message par erreur, veuillez nous en aviser immédiatement par réponse à ce courriel et le détruire (incluant ses fichiers joints) de façon définitive.

Hi Mike,

Thanks for following up and letting me know the solution you’ve figured out! Don’t hesitate to reach out if you have any further questions going forward. :slight_smile:

Best regards,


Sure thing. Please let me know what version of OctopusDeploy, this will be fixed in.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.