Using Workers, Service could not be located

I use version 2018.7.3.

I try to use Workers and Workers Pool. When I deploy using a worker I get this error when OctopusDeploy tries to stopp a service on the deployment target.
"Stopping ServiceTEST July 24th 2018 10:08:34Info
The ServiceTEST service could not be located. "

When I remove the worker pool and rebuild the deployment works fine without any warning

Hi @johant123456

Sorry for the delay in getting back to you.

Are you able to let me know what step you are using when this issue occurs? Just trying to replicate the issue so as much information as you can provide would be greatly appreciated.

I look forward to hearing from you shortly,


Sure …

The version I have installed is : 2018.7.3

  1. In the Process i select, a Workpool, in the execution Plan I choose “Worker Pool on behaf of roles” I do not change Roles. Run on a worker from “Default Worker Pool”. I choose a step that default stop a service.
  2. I do not create any workers, but use the default on the server.
  3. I rebuild and deploy in Octopus Deploy
  4. In the step that is “called Worker on behaf of …”
    July 26th 2018 07:59:08Warning
    No script syntax provided. Defaulting to first known supported type PowerShell
    July 26th 2018 07:59:10Info
    Stopping KPP.RemotingHost(KPPTEST18)…
    July 26th 2018 07:59:10Info
    Service KPP.RemotingHost(KPPTEST18) could not be located.

After more investigation I suspect that it is firewall.
I have opened firewalls from Octopus deploy server tcp 10933 to target Server, both directions.
Do I need to open more ports?

Hi @johant123456 ,

Just found this ticket still ageing out in my queue, sorry that you got the raw end of the stick twice!

Have you managed to sort this one out at all? From my experimenting with workers I don’t think it would be able to call a service on a remote machine unless you specifically call that machine via powershell and have remote scripting enabled. In which case you will also need TCP 5985 open on your firewalls as that is the port for WinRM.

Let me know if there is anything I can help with, I promise to get back to you this time!


No problem I’m glad I got a lead!
I’ll try it out, need to order some firewall openings!


Johan Tsung

HI Johan,

Glad I could give you a pointer! Let me know if there is anything else we can assist with,


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.