Using Octo w/Pack Erroring


I’m running into some problems with octo.exe with the pack option. I am running octo from a batch script that is being called after my TFS build drops to its file location. When the script runs, I get the following error:

Octopus Deploy Command Line Tool, version
Packing AlphaTaskService version 2014.10.24.161645...
Saving AlphaTaskService.2014.10.24.161645.nupkg to \\[serverName]\BuildOutput\AlphaTaskService\AlphaTaskService_20141024.17\..\..\_packages...
System.InvalidOperationException: Cannot create a package that has no dependencies nor content.
at NuGet.PackageBuilder.Save(Stream stream)
at OctopusTools.Commands.PackCommand.Execute(String[] commandLineArguments
at OctopusTools.Program.Main(String[] args)

The obvious thought is that my output folder is empty, except it is not. When I run the same command directly from command line, I do not get this error. Another piece of data is I’m getting two .nupkgs generated. One (AlphaTaskService.2014.10.24.161645.nupkg) is 0KB in size, the other is (AlphaTaskService.2014.10.24.161646.nupkg) 2,009KB. I’m guessing the script is throwing errors on the empty sized file, but I have no idea how this is getting created since I only have one call to Octo.exe in the script.

The batch script call is
%OCTO_DIR%\octo.exe pack --id=%TF_BUILD_BUILDDEFINITIONNAME% --basePath=%OUTPUT_DIR% --outFolder=%OCTO_DIR% --overwrite

Anyone have suggestions on things I should look for?

Thanks for your help!

Hi Travis,

Thanks for getting in touch! That is a bit weird. Can you please send us the full build log and we will see if we can figure out why it is being called twice.


Sorry for the delay on this, our Sprint stuff happened over the last two days.

I managed to get this fixed. It appears to have been something inside the build definition itself. Using a different definition did not yield the same results. So I recreated one for the project and now it works. I’m going to chuck it up to the mysterious ways of MSFT.

Thanks for getting back to me.