Upload timeouts

The joys of Africa… Our ADSL upload speed is a mere 0.35Mbps…

When a project contains multiple items to upload, some of the uploads don’t start:

2013-03-26 11:41:55 DEBUG Uploading package XXX.Web.Service.User 1.0.8014.8945 to tentacle
2013-03-26 11:42:19 DEBUG Beginning upload…
2013-03-26 11:43:19 ERROR System.ServiceModel.CommunicationException: The inactivity timeout of (00:01:00) has been exceeded.

Is there any config file that can be edited (didnt find any) to increase the timeout above?

Alternatively maybe i could include a servicemodel config in Octopus.Server.exe.config.

In the future maybe it would be nice to specify max concurrent uploads?

Hi Anton,

Thanks for letting me know, I’ll try to make it possible to tweak these settings and to set a max in the next release.