Upgrading Octopus from 3.3.27 to 3.13.3 Tentacle question

Hi, we are working on an upgrade plan to get to the latest version of Octopus and then to get on track to do scheduled upgrades more frequently to not get behind. My question is this:

With Octopus server requiring 4.5.1 going forward it says in the documentation that the tentacles can retain their current minimum .Net version. I am wondering will those servers that the tentacles reside on also have to have an upgrade of .net to 4.5.1 if we update all tentacles to the latest patch version.

Scott P

To add to this will the newest version of Octo.exe also require 4.5.1 .Net Framework to work properly ? If so I will need to make sure my Jenkins Server has that upgrade also.

Hi Scott,

Thanks for getting in touch! For the latest Tentacles you do need 4.5 https://octopus.com/docs/installation/installing-tentacles
If you have servers that are stuck on less than 4.5 you need to install Tentacle 3.0.26 and then lock the Tentacles to that version or they will continually tell you they are out of date and require upgrading.

We would recommend if your Tentacles can be upgraded to 4.5 that you do so and get the latest Tentacle as you can then use TLS 1.2 and also patch security updates from Windows.

Please let me know if I can expand on any of this information.

But if we lock the tentacles do we lose functionality? I’d be concerned about a deployment process having to be written two different ways because of different tentacle versions.

Hi Scott,

Calamari does the heavy lifting when it comes to deployments and processes. Tentacle does not. That was our intention with this model and why we can support older and newer server OSs.
Octopus and Tentacle have not needed to have matching versions since 3.0.


I ran a powershell script across all of our tentacles through a project which shows 4.5,4.5.1 and 4.6.1 installed on all of our machines so we should be good to go.

Last question. I see that on some machines we have 2.0 installed along with 3.0 and 4.5. When a deployment occurs with a powershell script in place it appears to be using 2.0 to execute however once we upgrade to the latest version of Octopus will it automatically pick up that 4.5 is already installed and just swap to using that ?

Let me re-phrase the above. I am seeing that the CLR Version is 2.0 however I am pulling back 4.5 .net framework. Is this fine or will we need to install the Windows Management Framework 4.0 on the servers to get powershell up to 4.0 ?

Hi Scott,

It is fine :slight_smile: Calamari needs to work with specific (low) versions of both .NET and PowerShell as it is supported across multiple versions of Tentacle.
The higher .NET version is mainly for security protocols on Tentacle and it will work.

Please let me know how your upgrade goes and if you need any assistance.