Upgrade from 3.2.14 to 3.2.22 causes Tentacle upgrade to fail


I upgraded our Octopus server from 3.2.14 to 3.2.22. I got the usual suggestion to upgrade our tentacles, so I tried upgrading one. I immediately got “An error occurred when sending a request to ‘https://xxxxxx:10933/’, after the request began: Object reference not set to an instance of an object.”

Performing a health check on that tentacle yields the same error message. Restarting the tentacle doesn’t help.

As a result, this particular tentacle is now dead in the water. I can try uninstalling and re-installing the tentacle entirely, but I hope this isn’t necessary for all of our tentacles. Any advice?

Hi JP,

Thanks for reaching out. I’m afraid you’ve been bitten by the 3.2.14 bug that prevented Tentacles in that version from talking to Octopus Servers in any other version (see github issue)

On the thread below I describe a set of steps to fix this issue. Please take a look at it and let me know if you have any questions.