Unsupported file extension `.gz`


We have a deployment job which is failing with the error "Unsupported file extension .gz" when trying to extract a package e.g.:

Extracting package: path\to\package.tar.gz 
Unsupported file extension `.gz`

For what it’s worth we’re running this step on the Octopus Server rather than a Tentacle in order to run a custom script.

This was working previously but we’ve recently updated to 2018.4.0. Apologies if this is fixed in a subsequent patch version but I’ve checked the release notes and didn’t see anything obvious.

Let me know if there’s any other info you needs.


Hi Paul,

Thanks for getting in touch! I believe the below paragraph should explain this issue. However this is only the second reported case I have seen so some of the details could be slightly different.

It looks like this occurs because the acquisition phase for tasks that run on the server like Azure or AWS steps bypass some of the new file caching mechanisms. As a result the file extension isn’t properly getting picked up when Calamari goes looking for the expected package because it is expecting the newer file naming structure which was built to better support the new feed types that have been introduced .There are some changes coming along in the future that will ensure that server steps work in the same way as standard steps and so the package acquisition process will work as expected however that is not currently being worked on.

Unfortunately the only work around we currently have is to suggest using a .tgz file extension or even just a .zip.

Doing so should get your deployments working again.

Let me know if this is not an options or if your have any other thoughts or questions here.

Looking forward to hearing from you.

Best regards,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.