Unable to register the tentacle with Octopus Server

Hi All, I am facing the following issue and below is the context:

  1. I am the space manager and have created my API keys.
  2. I launched an EC2 instance and installed tentacle on it.
  3. I have created an environment named “test” in Octopus.
  4. Since I have tried manually registering tentacle from the GUI however that did not work so I am now trying it from the cli using the below command:
    .\Tentacle.exe register-with --instance Tentacle --server https://xxxxxx --apiKey API-XXXXXX --force --console --comms-style TentaclePassive --environment test --role testrole --tenant test
  5. I am getting the following error message:

Could not find the environment named test on the Octopus Server. Ensure the environment exists and you have permission to access it.
at Octopus.Client.Operations.RegisterMachineOperation.GetEnvironments
at Octopus.Client.Operations.RegisterMachineOperation.ExecuteAsync
at Octopus.Tentacle.Commands.RegisterMachineCommandBase1.RegisterMachine at Octopus.Tentacle.Commands.RegisterMachineCommandBase1.StartAsync
at Octopus.Tentacle.Commands.RegisterMachineCommandBase1.Start() at Octopus.Shared.Startup.AbstractCommand.Start(String[] commandLineArguments, ICommandRuntime commandRuntime, OptionSet commonOptions) at Octopus.Shared.Startup.ConsoleHost.Run(Action1 start, Action shutdown)
at Octopus.Shared.Startup.OctopusProgram.RunHost(ICommandHost host)
at Octopus.Shared.Startup.OctopusProgram.Run()
Terminating process with exit code 100
Full error details are available in the log files at:
If you need help, please send these log files to https://octopus.com/support

  1. Checked the logs @ D:\Octopus\Logs and they have the same error message as mentioned above with nothing additionally useful.
  2. I checked my VPC flow logs and it shows the bidirectional traffic between my Octopus server and the tentacle EC2 instance however the traffic is only between TCP 80 and 443 (Should I see the traffic between some other ports as well, e.g. tentacle listening port 10933 and 10943)? BTW, I have allowed all kind of TCP traffice between EC2 and Octpus server in the security groups.
  3. Please suggest. Thanks in advance!

Hi @asw,

Thanks for getting in touch!

I noticed that you mentioned that you were a Space manager, yet your Tentacle register command hasn’t specified a space (missing --space=VALUE), which I think could be the cause of the error. Without specifying a space it would be attempting to register in the Default space, where you may not have permissions and/or the environment test doesn’t exisit.

If you can try adding the spaces switch and advising if you are still having problems that would be greatly appreciated.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.