Unable to make modifications to project, groups, roles after upgrade

After i upgraded from 1.0.x version to this morning my octopus is broken in that i cant perform the above critical tasks & is impacting our production releases. This is the javascript error i get - i tried in firefox as well IE8 but no luck

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C; .NET4.0E; AskTbORJ/
Timestamp: Wed, 21 Nov 2012 18:17:07 UTC

Message: ‘3’ is null or not an object
Line: 1
Char: 189478
Code: 0
URI: http://octopus.vdc.volusion.com/bundles/jquery?v=faI_mN36UuPi3MYRHSWW_keQ1sUsggKhKb44TQ4fp201

We’re having the same issue too on both IE 9 and Chrome.

SCRIPT5007: Unable to get property ‘3’ of undefined or null reference
jquery, line 1 character 189471

I’ve also noticed you cannot re-order deploy steps which seems to have the same root cause as mentioned earlier.

Hi Arvind and Michael,

The problem is some left over javascript files from the old installation that weren’t removed. Please:

  1. Uninstall Octopus server
  2. Delete the contents of C:\Program Files (x86)\Octopus\Portal\Scripts
  3. Reinstall the Octopus server

Alternatively you can try just deleting C:\Program Files (x86)\Octopus\Portal\Scripts\jQuery-ui.min.js and doing an iisreset.

Sorry for the trouble this caused you and I hope this helps,


Thanks Paul,

I’ve just deleted the jQuery-ui.custom.min.js file and iisreset for the win.


Ditto - i made this change last week like Mike mentioned - deleted jQuery-ui.custom.min.js & iisreset solved it