Unable to delete step because of ARC

I’m trying to delete a step in a project, but I get this error message:

There was a problem with your request.

The step ‘Deploy webservice’ is linked to Automatic Release Creation (ARC) and must remain linked to the Built-In feed. Please remove ARC settings if you would like to make this change. ARC settings can be found at Project > Triggers https://g.octopushq.com/AutoReleaseCreation

But there is no ARC configured for this project (or any other project), there is absolutely nothing in Triggers.

Hi @paw_baltzersen,

Thanks for getting in touch!

The triggers section can look blank even when ARC is enabled, are you definitely not seeing anything to the right of the screen e.g.

If ARC is completely disabled, then could you try hitting the Setup button and linking it to the ‘Deploy webservice’ step. Then once configured, hit the Disable button to remove it and try to delete the step again. It could just be an errant flag that will get removed correctly doing this.


This is how my Triggers page looks like. But there is not Setup button.

Just to add to the weirdness, it’s actually not the ‘Deploy webservice’ I’m trying to delete, but the Slack step.

Ah, I think I know what has happened here.
The button only displays if you have a step that is using the built-in repository.
So, if the following actions take place, it can be enabled and then disappear.

  • Have a package deploy step using the built-in feed
  • Configure ARC against that step
  • Edit the step to use an external package feed

A quick fix for this will be to add a new step to your deploy process to deploy a package from the built-in repository. You should then be able to see the Disable option in the triggers page. Once it is disabled, you should then be able to delete the step.

It might just be the reason for this. I didn’t create this project, so can’t say for sure.

I tried your fix, but I can’t add the new step.

Seems this project is completely locked down because of this.
It’s a small project so I think I’ll just create a new project. We’ll loose the deployment history, but I think that’s ok.

A side note. I also tried to change back to the build-in feed, but also got an ARC error.

That does seem strange, the message seems to be one that you would expect to see when first attempting to switch from a built-in feed to an external one, but clearly that has already occurred.

One possible solution would be to amend the project in the database. In the dbo.Project table there is a column named AutoCreateRelease. Setting it to 0 for this project should hopefully resolve the issue.
Obviously, as this is a database change, you’d want to grab a backup first.

If you’re happy to re-create the project, it may be the “safer” option.

Just so that I can try recreate this, can I check what version of Octopus you’re currently using?

I’ll have a look at the database and see if that fixes it.

We’re using version 2019.12.2, I could try .4 but I doubt it’ll fix this issue.

Your database hack worked :slight_smile:
Thank you for the help!

If it is allowing you to edit the steps now, just to be sure that there are no odd links left around it would be a good idea to edit the Deploy webservice step to use the built-in feed again, then enable and disable the ARC before switching it back to External feed.

Ok I’ve done that now, thanx again.

1 Like