Unable to configure tentacle over remote powershell session

I need to deploy and configure tentacle on multiple servers. Using Powershell I have installed tentacle with invoke-command OK.
Unfortunately all Tentacle.exe commands to configure tentacle over remote session fail with error:
"Cannot start service from the command line or a debugger. A Windows Service must first be installed (using installutil.exe) and then started with the ServerExplorer, Windows Services Administrative tool or the NET START command."
Tried interactive and non-interactive session using full path or running exe from install dir- same result
Works fine from local PS session. Any ideas how to get this to work remotely?
Thanks, Kasper

Hi Kasper,

Thanks for getting in touch! You’ll need to pass --console when calling Tentacle.exe via command line to force it not to try and run as a service.

You’re also likely to run into problems generating certificates when installing Tentacle via PS remoting. Here’s a couple of links that can help:


Hope that helps!


Thanks Paul, worked great!
Cert generation is not an issue remotely when delegating credentials and remoting with -Authentication Credssp.

Had the same issue, and adding the --console switch worked for me too! Glad I searched the forum before digging too deep! :slight_smile:

I had the same experience, not being able to use the Tentacle via PS Remoting. Found this thread! Maybe this should be part of the on/line help in the tentacle? I note saying that the --console.

A better alterantive (I think :-)) could the Tentacle.exe sense if it is run under a PowerShell remote session and if so, default to using the --consol behaviour?


+1 to the --console solution being added to the example scripts on http://docs.octopusdeploy.com/display/OD/Automating+Tentacle+installation

Added to the documentation