TypeError: Cannot read property isMultiTenancyEnabled of null

We upgraded from 2018.9.12 to 2019.3.3. Upon first login we got this error.

The error is not mentioned in the Octopus logs. I can’t get the error to show up again but I’m nervous to deploy Octopus to our Production environment without knowing what this means.

It looks like other folks are getting the same error
topic 22483
topic 22685

Hi Bob,

Thanks for getting in touch! I’m terribly sorry to hear you’ve hit this issue. Unfortunately we haven’t yet had any luck in reproducing this behavior, however. Out of curiosity, did you get this error to not show up again by a hard refresh (CTRL + F5) in your browser, or did it require a server reboot like mentioned in the other report you linked to?

I look forward to hearing back and getting to the bottom of this one.

Best regards,


Actually no I just tried connecting again and was able to connect the second time. It seemed to happen upon the first user connection after the upgrade. After I tried connecting again then I got the little Octopus icon with the animated lasso and it connected just fine. I did not reboot the server after the upgrade or after I got the error message. No other users have seen the error to my knowledge.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.