The remote server returned an error: (405) Method Not Allowed

I am trying out Octopus
I successfully pushed a nuget packet to the built-in Nuget-Server of Octopus.
However when I use the NuGet Test feature, I get the above error.
I used the same url that was suggested to push the packet: http://[our ip address]/Octopus/nuget/packages
Obviously the [our ip address] contains the actual ip address and not the string “[our ip address]”, I just did not want to publish it here.

Am I using the built-in NuGet server the wrong way?
How am I supposed to be able to see it’s contents?

Thank you for your help.


Thanks for the report. Could you share a screenshot of the page when the error occurs?


Hi Paul

It looks like this:
The above error occurs after I press Search. It does not matter if I type in a package name or not. The same error shows up.

Yesterday, I had the same error message when I selecting the built-in Nu-Get server in a “Deploy a NuGet packet” deployment step. But today that seems to work ok.

I hope this helps.
Kind regards


Can you send me a screenshot of your NuGet tab, with the list of packages?


Hi Paul


This is the list from the NuGet repository configured as a directory. The built-in repo does not show me any packages, only the error message I sent you.


Hi Torsten,

Sorry, I wasn’t clear. Can you send me a screenshot of the list of NuGet feeds? The page that you see when you click on the Configuration area, and then the NuGet tab.


Here you go.



I never noticed the Test>> button for the Built-In NuGet server. That test does show me the packages.
I am sorry for the confusion. I got rid of the entry “Built-In NuGet Library”.
I think that resolves the issue. (You helped me by just having me look at that page again)

Thank you

Thanks Torsten, we’ll look at how we can make using the built-in feed clearer!