The package was not found in the feed

We have recently upgraded Octopus Deploy 2021.1 (from 2017.8) we are using an internal Nexus Repository for our nupkg feed. We have a unique packaging and naming format… its not pure semver

Within the release pipeline “Deploy a Package” step . it only appears to like packages that have more straightforward naming conventions.

for example

2021.4.0 works.
but more complex build ids like 2021.4.0.0-11.50.210609.aabbccc will not work… (we need to use this format) and it worked ok in 2018.7

otherwise we get a red message “The package was not found in the feed”

any suggestions.

Hey Nigel,

Thanks for reaching out.

Assuming the version 2021.4.0.0-11.50.210609.aabbccc is an exact example, the problem with this one is that before the dash you can only have 2 dots. If you make it 2021.4.0-11.50.210609.aabbccc instead, it will work.

Unfortunately, in our newer versions, valid semver is required. You can use a semver checker online to ensure that the rules are being followed.

If that is not an exact version, there is a somewhat similar issue here: Some Valid Versioning usage in External Feeds (GitHub Nuget) will result in Package Not Found in Feed · Issue #6817 · OctopusDeploy/Issues · GitHub

Please let me know if it looks like your versioning works in a semver checker and yours is also another case of the above issue, or if you have any other questions or concerns.


Hi Jeremy,
thanks for the quick reply. Yes by changing the format to this worked ok


We will need to change our build naming convention but appreciate we are past this issue now.

thank you

1 Like

Hi Nigel,

You’re very welcome.

Thanks for updating me.

Please let me know if you have any other questions or concerns. I hope you have a great rest of your week.


Hi Jeremy, thank you.

I do have a different query

It’s along the lines if this post.

We have recently upgraded to Azure DevOps Server 2020 (from TFS 2017.1) and Octopus Deploy 2021.1 (from 2018.7).

We are not able to pull in projects from Octopus Deploy to Azure DevOp within the Releases.

I have created a connection to Octopus using an Octopus Service Account / with API Key – using FQDN over https and server name via http.

Added Azure DevOps Server url to CORS list on Octopus. (also changed to * to test also)

Upgraded the Azure DevOps Octopus Deploy Integration extension from 2.0.44 (used in TFS) to 4.2.472

I can see from the above ticket version 2 does not work. I have tried V3 and V4 and get the same error in the Azure DevOps browser console
Data source with name OctopusAllProjects could not be found for the given service

We don’t have any “Spaces” used just the “default” but nothing appears in any of the drop downs.

Any thoughts?

Hi Jeremy
I have also resolved this issue.

I had not given the Octopus Service Account the correct permissions. (as per instructions here)


Hey Nigel,

Sorry about the delay in the response as I was off shift being US-based.

Thanks for updating me and the thread with the resolution.

Please let me know if you have any other questions or concerns but I hope you have a great rest of your week.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.