The package step provided could not be found in the project's deployment process

I was modifying deployment steps this morning and deleted an old step that the versioning was tied to. Now I have a blank entry in the versioning step and it will not let me chose the correct step. Instead I get this error:

There was a problem with your request.
The package step provided could not be found in the project’s deployment process.

I ended up re-creating the project from scratch and deleting the bad one. The variable creation was the worst part.

Hi Scott,

Thanks for reaching out. I tried to reproduce this with the below steps in 3.5.1 but it worked as expected on my end. Can you double check that these steps allow you to reproduce this error?

  1. Add 2 package deployment steps to a project.
  2. Tie the release versioning strategy to one of them.
  3. Delete that step.
  4. Attempt to tie the release versioning strategy to the other package step (which should now be the only one in the process).

If you are using different steps to repro this, please let me know how you are doing it so I can reproduce it.

Also could you please let me know which version of Octopus are you running?


I’m having this problem repeatedly and I cannot figure out the cause. It’s really crippling my progress.

Any thoughts as to what is going wrong?

Hi Matt,

Would you mind picking up a time from the link below so we can schedule a call to show me the exact error you are getting?


I’ve actually been through the pain of recreating lots of projects. I even exported some but couldn’t see any differences except IDs.

Upshot is I don’t have any problems at this current time unfortunately…


Hei guys,

I have the same problem.
Steps to reproduce:

  1. Clone an existing project
  2. Go to settings and disable it
  3. Add steps
  4. Go to settings and enable it
  5. ERROR: The package step provided could not be found in the project’s deployment process

Hi @Bogdan.Petea,

I couldn’t reproduce this with those steps unfortunatelly. Is there a chance you can pick a time on my calendar to schedule a screensharing sessiong so you can show it to me?

The faster I can get repro steps for this, the faster we’ll be able to fix it :slight_smile:


Had the same problem. Started the project by cloning an existing one, removed my existing ‘Deploy a Nuget Package’ step, then added the new ‘Deploy an IIS Web Site’ step. Got the error as soon as the new step type was added, configured & saved. The screen above gave the same error.

Also, if I modify the ‘Release Versioning’ to ‘Generate version numbers using a template’, and set the template to the default, I get the following error:

There was a problem with your request.
• A package step must be provided to enable automatic release creation.


After reviewing the project export sent by Jeff, and later on having a screensharing session with him (Thx Jeff!), I was able to track down the cause of the issue and came up with a fix, but unfortunately I’m still not entirely sure how to reproduce this bug without hacking my way around in the database manually.

The error message(s)

  • "A package step must be provided to enable automatic release creation."
  • "The package step provided could not be found in the project’s deployment process."

The above error shows up whenever the user tries to:

  • Add a step to the deployment process
  • Add a Library Variable set to the project
  • Change the release versioning stratgy
  • Enable/Disable Automatic Release Creation

The cause

This happens when the project’s JSON document has a reference for a step that no longer exists. The way to spot this is by browsing [octopus url]/api/project/[project id] and looking for:

  "AutoCreateRelease": true,
  "ReleaseCreationStrategy": {
    "ReleaseCreationPackageStepId": "9f33d94e-16f3-4069-8f2b-657f0012bbc5",
    "ChannelId": "Channels-222"

If AutoCreateRelease is set to True and ReleaseCreationPackageStepId has a GUID value, this means the the project is still tied to the step that no longer exists.

The Fix

Using the below API script you can set AutoCreateRelease to False and ReleaseCreatingPackageStepId to "" so the project no longer dependes on deleted step

Unfortunately at the time of this message we still haven’t figured out how to reproduce this error without tweaking the database manually (we we strongly encourage everyone to avoid). If we every get a set of steps that allows us to reproduce this, we’ll surely work on a more permanent fix.