The Local Security Authority cannot be contacted

I have been tasked with looking at how we can automate our deployment process as currently everything is done manually I was recommended Octopus Deploy from someone at our data center as he has used it in the past.

Im running version 2.6.0 on my local machine and I have installed the tentacle onto another machine (currently im just using Azure VM) but when I have it fully working I will be installing it on our build server and onto our physical machine at our data center (not sure if the issue is because using Azure VM - just trying to give you enough detail of the setup).

In my Azure VM, When i installed the tentacle it asked me for the server thumbprint which I got from the octopus deploy server running on my local machine, and completed setup. If can navigate to https://localhost:10933/ on the VM and I see the following message (after pressing continue to this website (not recommended) because of the certificate.

Octopus Tentacle configured successfully

If you can view this page, your Octopus Tentacle is configured and ready to accept deployment commands.

This landing page is displayed when no X509 certificate is provided. Only Octopus Servers with a trusted certificate can control this tentacle.

On my local machine where the server is installed I try to add the tentacle to the server using the hostname of my DNS within Azure (also tried the IP address). the port is set to 10933 but when I press discover I get the following error message.

The Local Security Authority cannot be contacted

I tried to google this but couldnt return any results, I did get some about expired passwords relating to remote desktop errors.

I have setup an endpoint within the Azure Web Portal for any requests coming on that port to be forwarded to my VM and the local Firewall on the VM is set to allow any requests on that port.

Does anyone have any ideas what I need to do?

Also, I am running on my local machine with a local admin account, my machine is also connected to a domain and the Azure VM is running with local admin account and no domain. The octopus deploy also uses a local login e.g. not windows.

Also in the diagnostics I can see the following which again, not sure if it is an issue.

The X509 certificate CN=Octopus Portal was loaded but the private key was not loaded. Furthermore, the private key file could not be located: Unable to obtain private key file name

Hi Stephen,

Thanks for getting in touch! Sorry for the delay, I had to activate the hive mind here for possible troubleshooting ideas. AD setups can be complicated. My first suggestion is to try to run Octopus under your own account to see if you get a different result (due to permissions).
This documentation is for Tentacle, but the process is the same for Server

Let me know what the results are.