The given key 'StagedPackage.Size' was not present in the dictionary


I’m running a self-hosted worker (polling mode). It’s currently setup to deploy some K8S resources to AKS. It was working just fine a few days ago, until today when I got the following error message during the “Acquire packages stage”:

"The given key ‘StagedPackage.Size’ was not present in the dictionary. "

Any idea what I did wrong? I’ve already restarted the Tentacle, without success.

Using Octopus Cloud. No production workloads yet, so it’s not a big deal, but hopefully we can get this fixed, so I can continue the development.

Hi @hrantian,

Thanks for reaching out. Could I get a full task log from a working deployment and a non-working deployment, please? Could we also have permission to log into your instance to take a look? If so, please let me know which instance is yours in a private message, you can also attach your task logs there.

Were there any changes you can think of between when it worked and when it didn’t? Is it the same package you’re deploying currently, or is the current one new? Has the package you’ve been deploying ever worked?

Please let me know.


To those following along or finding this thread in the future, the issue was resolved by rebuilding the VM and this time not installing Azure Pipelines Self-Hosted Agent, or the .NET 3.1 SDK. He noticed it stopped working after installing those, so he rebuilt and didn’t install those and it works again.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.