Tentacle Upgrade issues

We are receiving the following errors in event viewer when attempting to upgrade our tentacles from 3.3.11 to 3.3.13. The upgrade appears to be successful, but the tentacle service stops right away after it starts. This seems to be happening with every server in our environment. I am able to correct it by deleting the tentacle instance and reinstalling it within the tentacle manager, but I am not looking forward to reinstalling the tentacles on all of my servers. Any advice on a way to correct this?

6 FATAL Object reference not set to an instance of an object.
System.NullReferenceException: Object reference not set to an instance of an object.
at Octopus.Shared.Configuration.TentacleConfiguration.AreEqual(OctopusServerConfiguration left, OctopusServerConfiguration right) in Y:\work\refs\tags\3.3.13\source\Octopus.Shared\Configuration\TentacleConfiguration.cs:line 165

Hi Rhiannon,

Thanks for getting in touch, and thanks for letting us know about this.

We did get a couple of reports of this issue, so we’ve worked out what caused it, fixed it and released a new version - 3.3.14. That new version should resolve the issue.

Sincere apologies for breaking things, it’s something we try really hard not to do!

Hope that helps!


Thanks you for your help, we are all up to date now :slight_smile: