Tentacle refuses to appear in Environement

Octo 1.6.2 (server and tentacle). Tentacle is .net 4.5.1

I’ve installed a tentacle on a new VM and I’m trying to add it to one of my environments but it refuses to show up.

I can access the tentacle URL from the octopus server - so it’s not Firewall.
In the RavenDb management studio, I can see the machine document:

“Name”: “DEVTEST-03SBSUL”,
“Uri”: “http://devtest-03sbsul:10933/”,
“Health”: {
“Status”: “Online”,
“Version”: “”,
“LastChecked”: “2013-11-29T15:07:01.2938849+00:00”
“Disabled”: false,
“Roles”: [
“Environments”: [

On the document page, the side panel has “References” and that is DeploymentEnvironments-417 which exists and is the name of the enviroment I’m trying to add the tentacle to.

I have deleted all the indexes and restarted the octo server (and iisreset) but it still refuses to display.

Clearly the server knows it’s there, because a “CheckHealth” does list the tentacle and shows success.

I even changed the tentacle thumprint and re-added the tentacle - no joy.

I deleted the document from the management studio, rebuilt indexes again and tried to re-add.

Is it possible that there is corruption elsewhere in the Raven storage?

(we have noticed that the “Projects” drop down does not list all projects and Permissions sometimes are listed as (Everyone) permissions when they are actually specific groups. We were prepared to ignore these errors, but I really need to be able to get new tentacles listed…)

Hi Peter,

How many machines do you have (in total, and in that environment)?


Paul Stovell
Octopus Deploy
W: octopusdeploy.com | T: @octopusdeploy http://twitter.com/octopusdeploy

2 other machines in that particular environment but we have many other environments including a QA environment that may have 10+ machines and a staging environment with 10+. In total I would say 40 machines over 8 environments…

Hi Peter,

Would you be available to do a screen sharing session with me (perhaps via Skype) to try and figure out what’s going on here?


Sure thing. I’ll catch up with you on monday morning and arrange something for that day or during the week. My work email is pmcevoy@ezetop.com

Sent from an overpriced i-device

I’ve setup a skype account if you want to contact me:

I’ll be online all week except for this afternoon from 12.

I’m based in Dublin, co currently on UTC time…


Hi Peter, thanks, I’ll try to catch you tomorrow morning your time.

I seemed to have missed you yesterday, but I was stuck in meetings most of the day. Perhaps you can send me a skype contact request and we can arrange a proper time?

Thanks Peter, I’ve sent you a contact request.


Paul Stovell
Octopus Deploy
W: octopusdeploy.com | T: @octopusdeploy http://twitter.com/octopusdeploy

Hi Paul,
I still haven’t heard from you regarding this issue. I realize that you are working hard on 2.0 artefacts etc, and there is a very large timezone difference. But we depend on the current stable release of Octopus and will for some time. If you could even suggest a workaround or areas that I can investigate to get more information for you?

What I have seen is that after attempting to add a machine to an environment (and it not showing up) that the environment index does get updated: but the “machines” collection does not seem to list the new machine.

Hi Peter,

I’ll try to catch you on Skype; in the mean time, could you open the
RavenDB studio, go to the Indexes tab, and right click the
Raven/DocumentsByEntityName index, and reset it? It may take a little while
to run but it should make the machine appear in the machines collection.


Paul Stovell
Octopus Deploy
W: octopusdeploy.com | T: @octopusdeploy http://twitter.com/octopusdeploy

Thanks for getting in touch on Skype. Just for the record (and for the hive mind): Resetting the DocumentsByEntityName index worked.

Although I’m amazed because I did do the normal step of deleting all indexes at least 2 or 3 times. As you mentioned on skype, perhaps it’s something to do with how Raven uses Lucene internally.

Thanks again, and looking forward to using 2.0