Tentacle Extract is Missing Files

We have some generated file names that include [] (square brackets) and a , (comma).
e.g: BulkQueryResponseOperation[Request,Response].html

These files are in the packages and can be seen if you extract or nuget install the package however when looking at the C:\Octopus\Applications<env><release> folder they are not there. This obviously also means they are never copied to the custom directory that I have setup.


Thanks for reaching out.

The problem is not the comma, but the squared brackets. This is a known issue that will be fixed once we move to Nuget 3.0 https://github.com/OctopusDeploy/Issues/issues/1447

Sorry for the crappy news

Best regards,

Thanks for the very prompt response Dalmiro.

I see the Github issue was closed in June of last year, do you have a timeframe in which we can expect the fix to be live?

Hi - Since Nuget touches so many parts of Octopus, its not something we can add in a patch release. It has to be added in a major release (3.3 => 3.4 or 3.4 => 3.5) as it needs to be tested like there’s no tomorrow.

We are doing all we can to try to fit this change into 3.4, which should be out in the next 2 months. The fact that we created a new github issue for it a couple of days ago (which I totally forgot to mention in my previous reply) proves our intention: https://github.com/OctopusDeploy/Issues/issues/2428

Even though I’d really like to, I still can’t compromise 100% and tell you that we’re gonna do it for 3.4. This fix would solve not only this issue, but also another one that only bites our users with the biggest setups. So trust me when I say we’d also like to get this one out as soon as possible.

We might be able to tell “Yes or no” to 3.4 in about 1.5 months when we finish the development phase of the current features we are working on.

Sorry I can’t give you an exact date. Hopefully you’ll appreciate my honesty here :slight_smile:

Thanks for the response. We’ve worked around the issue for now by not using [] but looking forward to hopefully seeing Nuget 3 in the next release!

I certainly appreciate the candor.

Also waiting for square brackets filenames fix as well!

We have about 20 projects having this problem and there’s no easy workaround solution in our case…

Hi @Andris,

We already starter working on moving to Nuget 3.4 which uses semver 2.0. We are working super hard to fit it into Octopus 3.4


Has this been fixed in version 3.4? We have a project that is failing due to the square brackets so we need to know whether we should upgrade as a matter of urgency…

Many thanks

Hi @Al!

I can assert that for us this problem was solved after upgrade to 3.4.

Hi Al,

The bug was fixed after 3.4. I recommend you to upgrade to the latest version of Octopus to get that fix and many other plus lots of cool features. You can find the full list here: https://octopus.com/downloads/compare?from=3.4.0&to=3.7.6