Team City Plugin and octopus 2.0

Can you use both plugins for 1.6x and octopus 2.0?

Same issue here

after further inspecting what is on my TEST system here is the location of the plugins:
Directory: C:\BuildAgent\plugins\Octopus.TeamCity\lib

-a— 4/17/2013 2:53 PM 1524 Octopus.TeamCity-common.jar

-a— 4/17/2013 2:53 PM 586961 Octopus.TeamCity.jar

Directory: C:\TeamCity\buildAgent\plugins\Octopus.TeamCity\lib

-a— 2/21/2013 11:36 AM 1524 Octopus.TeamCity-common.jar

-a— 2/21/2013 11:36 AM 586961 Octopus.TeamCity.jar

When looking at the name of the 2.x plugins they are the exact same name. So the next question is the 2.x version backwards compatible?

Just tried the newer plugin for 2.0 on my team city server and this is the message I received:

[14:48:35][Octopus Deploy] Running command: octo.exe create-release --server --apikey SECRET --project Ohyah --enableservicemessages --version --deployto Development --waitfordeployment --packageversion=
[14:48:35][Octopus Deploy] Creating Octopus Deploy release
[14:48:35][Octopus Deploy] Octopus Deploy Command Line Tool, version
[14:48:35][Octopus Deploy]
[14:48:36][Octopus Deploy] Handshaking with Octopus server:
[14:48:45][Octopus Deploy] Error from Octopus server (HTTP 200): This Octopus Deploy server uses a newer API specification (2.0.0) than this tool can handle (3.0.0 to 3.0.99). Please check for updates to this tool.
[14:48:45][Octopus Deploy] Exit code: -7
[14:48:45][Octopus Deploy] Octo.exe exit code: -7
[14:48:45]Unable to create or deploy release. Please check the build log for details on the error.

The 2.0 version of the plugin adds a combo box where you can select the version of your Octopus Deploy server. If you select “1.0+” it will use the 1.0 version of Octo.exe. If you select “2.0+” it will select the 2.0 version of Octo.exe.

Hope that helps,


Missed that I’ll look for it and put the plugin back in place.

Paul what version of Team City?

Not sure if what I’m showing below is what you mean Paul. That is reason for the version question.


It looks like you must have an old version of the plugin installed. Attached is what the new plugin looks like - it has a drop down to choose the Octopus version.


dropping this plugin in the teamcity plugins directory solved my issue. Thanks for the help Paul