System Admin Audit Permissions Not Working

Has anyone else had trouble with this? We have a team with the System Administrator User Role, but if you navigate to a project, it will tell you there is no Deployment History/don’t have audit permissions.

However, if you edit that same team with the System Admin Role and specifically add in a project or Project group, you can then see the deployment history, audits, etc for them. You are supposed to be able to leave this blank and be granted access to all projects. This started when we upgraded to 2018.4.3

Surely this has to be a bug, right?


Thanks for getting in touch,

I’m sorry to hear you are experiencing this issue, I understand this behavior can be frustrating.

I’ve not been able to replicate this same issue in my own instance at this stage, unfortunately.

Based on the information provided in your query, I have a sys-admin team that has no scoping to a particular project/project group and when accessing the Project i’m not experiencing a permissions issue.

If possible, can you please provide an Export of one of the associated Users permissions (prior to including the Project/Project Group scoping?), you can produce this information via Configuration > Test Permissions in the Octopus portal. You’ll need to specify the User here and an option for Export will appear in the top right.

It would also be valuable if you could include a screenshot of the associated error itself and the Team settings found via Configuration > Teams related to this user.

Finally, can I also please confirm which version of Octopus you originally upgraded from?

I look forward to hearing back from you, your patience and understanding are greatly appreciated :slight_smile:

Kind Regards,


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.