Suppress CLI command output

I have a simple release process which actually just calls an AWS CLI tool. This step calls a bash script within my package which in turn invokes such AWS command. I’ve tried to suppress the verbose output by appending > /dev/null to the end of the command but that still doesn’t fix the issue. The deployment is successful but Octopus gets confused and thinks the output of the tool are errors. Attached is an image with shows the error output

Does anyone have any tips? Thanks in advance!

Hi Andre
Thanks for reaching out to our Support team.

Its a known issue that Octopus can misinterpret stdout as an error but still complete the deployment.
The best way to deal with it is to specifically call out the stderr/stdout and redirect it. This is more than redirecting to /dev/null as you can see below:

aws command 2>&1 > /dev/null

You can read about it here: Updating Linux - Octopus Deploy. (at the last step)

If for some reason you have issues with this, Octopus itself has methods to ignore stderr and other warnings:

I haven’t tested the above Octopus logging commands for a Linux aws cli command but I can test it in our labs if needed.

If you need more help with these suggestions, let me know.

Kind Regards,

1 Like

This did the trick, thanks for your help, @paraic.oceallaigh !

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.