Step Template sourced from package: How To

No matter what I try I always get an error
“Step templates that do not include a script body are currently not supported”
How do you format a csscript in a package in order to be able to load it as a custom step template?Have an inline custom step that works fine just need to figure out how to source it from a package.

Hi @PMSwetz, thanks for getting in touch,

This should definitely be possible in version 2019.5.0 or later. This is covered in our documentation, but not specifically called out. In order to achieve this you need to choose the Script file inside a package option and ensure you choose a package which contains your script. In addition to this, you would also need to ensure you use the .csx extension by convention for c# scripts.

There is however an issue with the package selector which is less than ideal to be aware of which we will hopefully have a fix for soon.

I am not aware of any other issues that would prevent you from using a step template which sources a script from a package. If the above doesn’t work for you, could you please share the version of octopus you are currently running?


That is what I had tried. I took the working script implemented in a step template, packaged it as is in a csx file and pushed it into octopus and then setup a new step template as script source = “script is contained in a package” selected my package. Whenever I tried to run it I get the “Step templates that do not include a script body are currently not supported” error. I also tried to export the working step template as json and packaged that and tried to use it but got the same error. Also looking at the script block in the Step template run task run test page it is empty. However the csx file is in the package and has the correct content.

We are cloud v2019.5.12

Hi PMSwetz,

Does the error present itself when running the step template via the script console direct from the step template section or is it failing when used as part of a deployment process? In the former case it’s a limitation which should be lifted once we implement ops processes and may be of particular interest.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.