Step Template Save As Copy not working

Latest server cloud version (2020.5.3)

I have an issue with the “AWS - Deploy Lambda Function”, so if you wanted to fix that too then that would be appreciated.

My issue though is when trying to fix it myself.
I click the Save As Copy button, give it a new name, but am presented with the error:

There was a problem with your request.

    The following Feed Ids cannot be found: feeds-builtin

Not sure what it’s trying to do, but it won’t let me save the copy and fix my own issue which is very frustrating.

The original issue I am having is trying to escape quote characters in the Environment Variables variable of the AWS - Deploy Lambda Function step template. We have a couple of password we send into env vars, so to stop PowerShell having an issue with them we are trying to quote them, but no matter what type of quotes we use or escaping, it never seems to work with the step template as it stands.
I think I can see the issue, but I cannot fix it myself.

Thanks in advance!

Ah I’ve found the error is due to the Step Template referencing it’s own Package variable as a Package Reference.
Still feels like a bug but I can work around it for now I think as I don’t need to reference my own package I don’t think. If I do I should be able to re-add it manually in my copied template.

Hi @ops,

Thanks for reaching out to us at Octopus Support!

Could you confirm if you’re in the default space when you’re getting that error?

We can dive into the original issue as well.


That’s a good point. This is in a non-default Space.
We’ve just started a new space for a new project.



Also if it helps… our env var parameters looks something like this:

URL="",USER="username",PASSWORD="password with+random characters!"

So far I haven’t found the magical combination of quotes that let me pass these into the step template.
The quotes just always seem to be stripped out inside the variable and so break the --environment variable when passed into the aws cli

As I was typing I’ve found the magic.
Seems that setting with single quotes inside my variable does the trick.
Escaping does not work

URL='',USER='username',PASSWORD='password with+random characters!'

Hi @ops,

Thanks for the updates! Glad you were able to do some troubleshooting on your end.

It looks like you ended up using single quotes to resolve the original issue, but have you found a satisfactory resolution to your secondary issue with the step template?


Hi @mallory.brewer.

Thanks for getting back.
No I would still consider the secondary issue of copying a Step Template a bug.
The workaround I used worked. Remove the reference to the package step, save as a copy, and then re-add.
In the end I didn’t need to make a copy, but the error is still present in the UI where I would expect the copy to work.

Hope this makes sense.

Thanks for your patience as I worked through my underlying issue :grin:

Hi @ops,

Thanks for confirming! I’m glad to hear the first issue is resolved, but I will look further into the secondary issue and see if we can reproduce and identify any bugs.

Please let us know if you need anything else!


Hey @ops,

Sorry about the huge delay, it looks like your ticket slipped through the cracks.

I’m going to take this ticket over and work it from here.

I just want to make sure you’re still having issues saving a copy of a community step template.

Could you please give me the start to finish steps to reproduce this on my end? Which community step template are you using and what are you changing before you try to save it? Is it always the AWS - Deploy Lambda Function template or any?

Please let me know if you have any questions.


Hi @jeremy.miller
No worries about any delay. Like I said it’s a bug that’s no longer affecting us as we didn’t have to duplicate the step in the end.

I’ve just confirmed the issue though is still present in the latest version of Cloud.

The steps to reproduce here are:

  1. Go to Library
  2. Go to Step Templates
  3. We’ve obviously got the AWS - Deploy Lambda Function template already installed but you may need to add it here.
  4. Click the template to View / Edit it
  5. Click Save As Copy (note we don’t need to change anything)
  6. In the dialog that pops up just click Save (again no need to change anything)

Error thrown: There was a problem with your request.
The following Feed Ids cannot be found: feeds-builtin

This is because there is a package reference included with this step.
If one removes this reference before saving the copy then the save works. One can then relink the reference to the package step in the copy.

I can also confirm that this issue occurs on other Step Templates that also reference a package step. See RoundhousE Database Migrations

Hope this helps.



Hey Mike,

Thanks so much for the clear repro steps.

I’ll get this passed along to the engineers as I’m sure you arent the only one who is going to run into this.

I hope you have a great rest of your week and please let us know if you run into any bumps in the future.


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.