"Start Mode" for a service install of a package of "Manual" doesn't work, service always tries to start

When I deploy my services using Octodeploy I don’t want them to automatically be started.

I used the “Configure Features” button to select “Windows Service”. Then under the section for “Windows Service: Startup” I selected for “Start mode” the option of “Manual”. This would imply to me that the service wouldn’t automatically start after I install it, right?

Unfortunately the service does start right after it is installed to the server.

I’m running Octopus Deploy

Thanks for letting us know. The startup mode only normally applies when the host machine boots, but I can see how this is confusing behaviour. I’ve added a ticket:


It would be optimal if there was the option to control whether to start the service or not after the deployment. Most of the time I don’t want to start the service until I’ve deployed other stuff as well.

Paul Mendoza
Development Manager
O (760) 233-4030 ext 117
C (760) 917-3753

Analytics. Intelligence. Empowerment. www.detectent.comhttp://www.detectent.com/