SSH: Tentacle fails health checks after disk space issue


This morning a colleague accidentally overflooded one of our test system and the debian machine went into read only mode on the file system :).

This has happend before so i logged in and did a cleanup at which point, after a reboot, we where out of the readonly mode.

But now the tentacle fails the health check claiming there is no file and a directory is missing.
It looks for the file in a new directory every time (see screenshot).
I tried moving the entire .octopus folder, hoping it would kick of a reinstall but it still gives me the same error.

What should I do?

Please note that I can see an incomming ssh connection fro octopus so there IS a connection. It simply fails to find the script for some reason.

I have also tried removing the ssh tentacle in ocotpus and then adding it again, same result.

Okay turns out that the ocotpus ssh user had lost its rights on the .ocotpus folder.
That fixed it :).
Im no linux expert so i think its cool that linux does “damage control” and rewoke permissions but maybe you could do a permission check before running the so that the error message in the log is better?

Hi Christian,

Thanks for the feedback, this is definitely something we could make clearer. I’ve created an issue on our backlog which you can track here: