Solved: 2020.4.10 - DeploymentCreate

Edit: Problem Solved


I have a problem with projects that are in the same project group, in the same space, using two different Environment Targets and lifecycle.

Project Group: “Projects”
Project 1 - Lifecycle “internal” - 2 machines with a role “INT.PROD”
Project 2 - Lifecycle “external” - 2 machines with roles “EXT.PROD”

As an administrator I have created a release for both projects, and deployed it to both projects.

I have created a Deploy User, in a team, with a limited set of permissions; simplified as scoped to:

Project group: Projects
Projects: Project 1, Project 2
Environments: INT…PROD, EXT.PROD

When this user attempts to re-deploy an existing release from Project 1 (environment-12) it goes ok.

When the same user attempts to re-deploy an existing release from Project 2 (environment-84) the user gets an error message that the environment (84) is unavailable or that the user does not have permissions.

If I give the team the permission “DeploymentCreate” in addition to the existing permissions (mostly view), then the “missing environment” under target environment for the deploymeny of the release will show up correctly. However, this is displayed correctly at all times for the other project (and environment).

Shouldn’t these two projects/environments have the same permission limitations?

Hey Alex,

Welcome to the Octopus Boards. Thanks for reaching out.

This definitely seems like a weird one.

Would you be able to privately message a permissions export for the affected user so that I can try to reproduce this behavior on my end? You do this in Configuration->Test Permissions.

Please let me know.


Hi, Turns out there was an error in the configuration; I saw it when looking at the test permissions page.
Thanks for the tips. :slight_smile:

1 Like

Hey Alex,

You’re very welcome. I’m glad to hear you worked it out, thanks for updating me.

I hope you have a great rest of your week!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.