"Runs on targets in roles" won't accept anything

I’m using Octopus 3.4.13. When creating a process in a project, I’m running into this issue.

The field “Runs on targets in roles” won’t accept anything and it won’t allow me to complete creating the process.

How/where can I add roles? Searched help and online and couldn’t find anything.

Found out that I need to install Tentacles as well. Did that. Now I cannot add machine because I’m running on a Windows 7 Enterprise OS. Reading thru’ the docs, even though you guys don’t officially support it, you don’t block it either. So was wondering how to add machine, so that I can create roles to create the process.

Guys, you should definitely improve your help/documentation. And don’t show blank values, if you already know that the tentacle or machine is not present, please say that. :slight_smile: You could have saved several hours for me. Remove any/every anxiety while trying out a product.


Thanks for getting in touch.

It is a bit confusing getting started with Octopus, that is something we are working on. There is a guide here that might help: http://docs.octopusdeploy.com/display/OD/Getting+started

If are you just setting up Octopus to get familiar with it, you can add a “Cloud Region” to your environment instead of setting up a Tentacle. A Cloud Region is basically a deployment target without an endpoint.

Hope this helps.