[Regression] Variables passed through by deploy release step can break the deployment

Seems like this one https://github.com/OctopusDeploy/Issues/issues/4466 has an regression

In our case we had Kubernetes Deploy Containers step, inside it we have single container having few environment variables passed from Library set

One of variable values had value like “secret\xxx” and while trying to deploy we got exact same error as in issue on github (meanwhile the same variable is used in good old IIS Website steps and everything is ok there)

Hope that helps

Hi @marchenko_alexandr,

Thanks for reaching out. Sorry you’re having issues with your Kubernetes step. Could you please provide me with some more information?

Could you please provide me with:
A full task log from a failure
A deployment JSON? To get this go to the Project, then the process section, then click the 3 dots to the right of add step and click download JSON.
Either screenshots of the variables/library variable sets, or the JSONs of those.

Did this functionality work for you at one point but stopped working after an upgrade? If so, which versions were involved?

And to clarify, this only happens with Library variable set variables and not project variables, and only within a Kubernetes Deploy Containers step?

If this information is sensitive please feel free to direct message me the information.


Hello did fight all morning with this one without success

Unfortunately I have deleted broken releases so can not find any logs in “Tasks” (my be they are some how hidden, we are in octopus cloud, so probably you can check them out)

Did also tried to create new project to replicate an issue, but somehow everything is working :thinking:

My thoughts and checks were:

  • whether it depends on project level variables vs variable sets
  • whether variable name have any inpact (in our case variable name was something like “Hello:World”)
  • whether variable type (default vs sensetive) have inpact

But all checks are ok, sorry, at moment I literally can not reproduce it

Hey @marchenko_alexandr,

I’m glad to hear you’re not having the issue anymore but that definitely is frustrating not knowing what caused the issue in the first place. We’ve all for sure been there. Unfortunately, those task logs will be gone if the releases are deleted.

If the problem crops up again please feel free to reach back out and we’ll dig in to the problem for you.

Have a great rest of your week.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.