Push to Internal NuGet Repository Not Working


I am working with the trial and when I use my MSBuild definition to push the OctoPacked NuGet package, I get a “your package was pushed” message in the logs, but the repository never seems to get it.

I have checked my API key, and the URL. If I run this via command line I get the same message, and still no package. If I upload the package through the Octopus UI directly that does work.

This is the command in my build definition:
/verbosity:diag /p:Platform=AnyCPU /p:RunOctoPack=true /p:OctoPackPublishPackageToHttp=http://MyDomain/app#/library/packages /p:OctoPackPublishApiKey=API-XXXXXXXXXXXXXXXXXXXXXX

Hi Corey,

Thanks for reaching out! It seems that you were pushing the package to the wrong URL. You can find the right URL to pass to the /p:OctoPackPublishPackageToHttp parameter on Library -> Packages as shown on the attached screenshot.

Hope that helps,

Totally forgot to attach the screenshot!

That fixed the issue. My bad for missing the URL being off.