Publish Runbook not enabled when Script Modules are changed

Hi Guys,

Since script modules are pulled in as part of the variable snapshot for a runbook I’d expect the Publish runbook option to be available after making that change to a runbook process.

Steps to reproduce this:

  1. Ensure you have a script module ready to use.
  2. Navigate to a project that only has runbook processes (in my case /app#/Spaces-2/projects/azure-environments/operations/runbooks)
  3. Navigate to the runbook process by clicking on the runbook, then the process tab (in my case app#/Spaces-2/projects/azure-environments/operations/runbooks/Runbooks-281/process/RunbookProcess-Runbooks-281)
  4. Add a script module to the runbook

Expected outcome:
Since the runbook is changed, I expected the publish runbook button to be enabled at this point.

Actual outcome:
The publish runbook button remains disabled.

Simple - make an innocent change (in my case whitespace in a comment in the PowerShell step that was using the script module.

If you need any more info, let me know. On a scale of 1-10 on how annoying this is, it’s only a 3 for me :slight_smile:


This also happens when you include a library variable set into the project that a runbook is in, the changes require the runbook to be published, but the button is disabled.

Hi Darryl,

Thanks for getting in touch! Sorry to hear you’re hitting this issue. I appreciate you bringing this bug to our attention and for your detailed report. Your clear repro steps were very helpful. :slight_smile:

I raised this as a bug report at the following link for you to track.

Another potential workaround would be to update the variables in the published snapshot, in case that’s of any help. That’ll pull the changes made to a variable set and/or script module in to the existing published snapshot.

Please let us know if you have any questions or concerns going forward.

Best regards,


Hi Kenny,

I found the option to update variables in the published snapshot workaround after I posted - in many cases that is more convenient.

Thanks for agreeing and logging it as a bug.


Hi Darryl,

No problem at all, good to hear you found the same workaround. :slight_smile:

Please let us know if we can try to help with anything else in the future!

Best regards,


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.