Problem with our Octopus deploy

Hi Team,

We are using Octopus deploy for our deployment into Dev, SIT, Preprod and Prod env’s which is integrated with Teamcity for build of code base. Once the build is done in Teamcity and nuget package is created and the package is deployed to respective environment. For one of our project Octopus deploy is failing to build with below error.
Downloading NuGet package COS.Service.SubmitClaims from feed: ‘http://XXXXXXXXX/httpAuth/app/nuget/v1/FeedService.svc/
March 23rd 2018 14:07:50
Failed to download package COS.Service.SubmitClaims from feed: http://XXXXXXXXX/httpAuth/app/nuget/v1/FeedService.svc/’’
March 23rd 2018 14:07:50
The package COS.Service.SubmitClaims version could not be downloaded from the external feed 'http://XXXXXXXXX/httpAuth/app/nuget/v1/FeedService.svc/’/’ after making 5 attempts over a total of 116s. Make sure the package is pushed to the external feed and try the deployment again. For a detailed troubleshooting guide go to

Problem started when we wanted to deploy a particular build number to Dev environment and instead of deploying the correct build it was deploying wrong build to dev environment. For ex: if the build number 1.0.125 (where 125 is the build number) in the Octopus log it said 153 is already in the cache and no need to download and it kept deploying 153 to the dev environment hence we changed the build number in Teamcity and tried to deploy it and again it failed in Octopus saying wrong version number and hence we reverted back the build number and tried to deploy and now we are getting the above error. Can you please help resolving this issue.

Hi, thanks for reaching out.

From the description you have provided, it appears that you wish to have Octopus deploy the version of the package that relates to a build number in Team City e.g. when the build number is 1.0.125, Octopus should deploy package 1.0.125. Is this correct?

Given that you are using Team City, I’m assuming that you use the OctopusDeploy: Create release step. By default this step will deploy the latest version of a package, regardless of what the Team City build number is. To specify a particular package version, you need to supply the --package argument in the Additional command line arguments field. This option is documented at In your case the argument would look something like --package COS.Service.SubmitClaims:1.0.125 or --package See the documentation at for more information on Team City build parameters.

You may also be running into an issue where the newly uploaded packages are not made immediately available from external feed. It is not uncommon for external feeds to take a minute or so to allow a new package to be downloaded. You can verify that a package is available for download using the nuget cli tool with the command nuget list COS.Service.SubmitClaims -AllVersions and ensuring that the package version is listed in the output.

If this does not solve the issue then I’ll need to get some additional information to help identify the underlying cause:

  1. Screenshots of the Team City steps that push the packages and create the releases in Octopus.
  2. A copy of the deployment logs. The process of downloading these logs is documented at

Matthew Casperson

Hey Matthew,

That solved my issue. Thank you very much for your help, you saved my day. you are a legend.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.