Problem with new install (Loading, please wait...)

I just performed a new install of version on a freshly built Windows 2008 server with a trial license. After completing the install, I clicked to browse the site (http://localhost/octopus/app) and I get a page that says “Loading, please wait…”. I’ve waited 15 minutes, refreshed the page, stopped and started the service, and even reinstalled but still have the same problem. I don’t see anything unusual in the windows or octopus logs. If I browse to /api I get a json file. Any ideas on what to try next?

Hi, I’ve got exact same behavior today. The version is on Windows 2008. I also noticed that when I tried to browse RavenDB (default port http://localhost:10931/raven/studio.html) I’ve got Connect to … dialog. In my configuration authentication is set to username / password.


Tried to access the same page in Chrome and everything just worked fine. I guess that it has something to do with javascript settings of IE at the server…

It’s good to know that it works in Chrome, maybe there is a setting I can adjust to get it working in IE. Unfortunately, I don’t have the option to install another web browser on this machine – I need to get it working under IE 9.

Hi James,

IE9 should be fine - you might use F12 and check the developer console to see if there are any errors logged (JavaScript disabled, 404s etc.)

If it is a server machine with something like IE “enhanced security configuration” enabled there’s the possibility that’s interfering - can you share any more info about the machine?

If a Skype screen-sharing session is an option for you let me know.


Running the developer console I see the following javascript errors:

SCRIPT1014: Invalid character
octopus.min.js, line 9 character 8173<0>
SCRIPT5009: ‘Octopus’ is undefined
app, line 129 character 3<0>

The site is in the Trusted Sites list (Medium level) and “Enable Protected Mode” is turned off.

Hi James,

Would you be available for a Skype screen sharing session (or another technology)? My Skype name is paulstovell, or let me know what works for you.