Problem with HTTP and HTTPS bindings

What my end goal was to have http deployments to one region and https deployments to another region which were configured via the IIS site and app pool setup step. How I accomplished this was by adding 3 variables that changed between regions:

binding-type -> Protocol Field
binding-port -> Port Field
ssl-thumbprint -> SSL Thumbprint Field

I then scoped these variables for the different regions so that I could deploy too both http and https from variables. When I deployed to the http region it worked and the variables were:

binding-type -> “http”
binding-port -> “8086”
ssl-thumbprint -> “”

But when I tried to deploy to the SSL region it did not work because the ssl thumbprint was received as blank. Here were the variables

binding-type -> “https”
binding-port -> “443”
ssl-thumbprint -> “”

On the UI the bindings list does not show the ssl thumbprint on the screen which I thought was also odd.

I dont know if this is a bug or just by design but it seems like this should work so any help would be appreciated.



Thanks for the report. Yes, the thumbprint should show on the binding list, it looks like something may be failing on the UI side here. I’ve raised a ticket to investigate:

One thing you might try is to change the protocol to HTTPS explicitly, and see if this shows the correct information in the binding list. Using two different steps, one HTTP and one HTTPS, with the steps scoped by environment, might be a possible workaround.